Сервак выдает свой IP'шник

Тема в разделе "Администрирование серверов", создана пользователем XANDER-CAGE, 28 окт 2011.

  1. XANDER-CAGE

    XANDER-CAGE Пользователь

    Сообщения:
    123
    Симпатии:
    23
    такая трабла, сервак выдает IP'шник бриджа юзверям, тем самым юзвери ходят на трекер с IP сервера, ну и аннонсер видит их как серверные. Использую в качестве веб сервера nginx, настроен бэкэндом, что делать я пока не знаю, решил отписаться. Вот схемка
    [​IMG]
     
  2. diden05

    diden05 Пользователь

    Сообщения:
    262
    Симпатии:
    76
    Стесняюсь спросить, а nginx бэкэнд для чего?
     
  3. XANDER-CAGE

    XANDER-CAGE Пользователь

    Сообщения:
    123
    Симпатии:
    23
    diden05, у меня связка была апач + нгинкс. В прочем проблему решил, настроил сервер человеческим образом.
     
  4. diden05

    diden05 Пользователь

    Сообщения:
    262
    Симпатии:
    76
    mod_rpaf так вроде.
     
  5. dexer7

    dexer7 Пользователь

    Сообщения:
    81
    Симпатии:
    72
    На Debian 7
    Скачиваем сам модуль:
    Код:
    apt-get install libapache2-mod-rpaf -y --force-yes
    ну и правим файл /etc/apache2/mods-enabled/rpaf.conf меняем на IP вашего сервера.
    Перезагружаем Apache:
    Код:
    /etc/init.d/apache2 restart
    На CentOS 6
    Скачиваем сам модуль:
    Код:
    rpm -ivh http://download.ispsystem.com/repo/centos/release/6/x86_64/mod_rpaf-0.8.2-1.el6.x86_64.rpm
    правим файл /etc/httpd/conf.d/mod_rpaf.conf меняем на IP вашего сервера.
    ну и незабываем:
    Код:
    service httpd restart
    Код:
    service nginx restart
    Чтобы проверить корректность работы mod_rpaf создате в корне вашего сервера php файл с содержанием:
    PHP:
    <?php echo $_SERVER['REMOTE_ADDR']; ?>
    При открытии вы увидете свой IP адрес, с которого вы вошли в интернет - значит mod_rpaf работает.
     
    Последнее редактирование: 3 дек 2015
    Exile нравится это.

Поделиться этой страницей