У кого нибудь есть проблема с Nimp'ом?

DarkMod

Пользователь
#1
Дело в том что когда создаю тему или удаляю(ТП) выскакивает ошибк. И это ошибка выскакивает только в нипе
Код:
#001265 Data truncated for column 'post_subject' at row 1

INSERT INTO bb_posts_text (post_id, post_subject, bbcode_uid, post_text) VALUES (4, 'asdasd', '', 'asdasdasdsad')

Source  : includes\functions_post.php(247) :: db1.2
IP      : 127.0.0.1
Date    : 2011-06-30 22:16:36
Agent  : Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0
Req_URI : /posting.php
Referer : http://test.ru/posting.php?mode=newtopic&f=1
Method  : POST
PID    : 05504
Request : Array
(
    [mode] => newtopic
    [f] => 1
    [add_attachment_body] => 0
    [posted_attachments_body] => 0
    [subject] => asdasd
    [fontFace] => -1
    [codeColor] => black
    [codeSize] => 12
    [codeAlign] => left
    [codeUrl2] =>
    [message] => asdasdasdsad
    [post] => 1
    [decflag] => 2
    [attach_sig] => on
    [topictype] => 0
    [filecomment] =>
    [poll_title] =>
    [add_poll_option_text] =>
    [poll_length] =>
)______________________________________________________________________________
Денвер, аппсервер, и т.д проблем не замечалось
--- добавлено: 30 июн 2011 в 20:24 ---
Проверил на Vb и WordPrees такая же ерунда
 

Lange

Пользователь
#4
в конфиге mysql что то изменить нужно...
my.ini
замени на это:

[mysqld]
port=3306

max_connections=160

basedir=C:/nimp/component/mysql/
datadir=C:/nimp/component/mysql/data/
#innodb_force_recovery = 4

log-bin=/nimp/component/logs/mysql/
tmpdir=/nimp/component/temp/mysql/

skip-name-resolve
#skip-bdb
character-set-server=utf8
default-storage-engine=MyISAM
sql-mode="NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"
query_cache_size=8M
table_cache=320
tmp_table_size=10M
thread_cache_size=8
max_allowed_packet=8M

#*** MyISAM Specific options
myisam_max_sort_file_size=100G
;myisam_max_extra_sort_file_size=100G
myisam_sort_buffer_size=9M
key_buffer_size=8M
read_buffer_size=64K
read_rnd_buffer_size=256K
sort_buffer_size=256K

federated=ON

#*** INNODB Specific options ***
# innodb_additional_mem_pool_size=15M
# innodb_thread_concurrency=8
# innodb_mirrored_log_groups=1
# innodb_log_files_in_group=3
# innodb_log_buffer_size=15M
# innodb_log_archive=0
# innodb_file_io_threads=4
# innodb_lock_wait_timeout=30
# innodb_buffer_pool_size=100M
# innodb_log_file_size=50M
# innodb_data_file_path = ibdata1:2000M;ibdata2:2000M:autoextend
# innodb_flush_log_at_trx_commit=2

[client]
port=3306

[mysql]
default-character-set=utf8
;character-set-server=utf8
 

DarkMod

Пользователь
#5
Locer, не поверишь тоже самое
--- добавлено: 30 июн 2011 в 21:17 ---
PheRum,
Locer,
Если у вас работает, скиньте свой исходный nimp. Проверю
 

DarkMod

Пользователь
#7
XANDER-CAGE, Обязательно
--- добавлено: 30 июн 2011 в 21:36 ---
Когда удаляешь последнюю тему выдает ошибку.
 

PheRum

Разработчик
#8
DarkMod, mysql точно перезапустился? я скрлько помню у него там грабли с перезапуском, его проще вырубить диспетчером задач, чем заставить перезапуститься
 

DarkMod

Пользователь
#9
PheRum, да точно, через ДЗ перезапускал и комп перегружал,
Попробую еще раз