решено Работа на php 5.2

lexafromorel

Пользователь
#1
сейчас на хостинге выдается следующий лог - Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or '(' in /home/u687542402/public_html/common.php on line 23. Я так понимаю что это из-за того что крон поддерживает только версию php 5.2. Может кто в курсе как поправить?
Да и трекер (2.1.5) на версии php 5.2 выдает такую же ошибку - она что перестала поддерживаться?
 
Последнее редактирование:

Virtuoz

Пользователь
#2
сейчас на хостинге выдается следующий лог - Parse error: syntax error, unexpected T_STRING, expecting T_CONSTANT_ENCAPSED_STRING or '(' in /home/u687542402/public_html/common.php on line 23. Я так понимаю что это из-за того что крон поддерживает только версию php 5.2. Может кто в курсе как поправить?
Да и трекер (2.1.5) на версии php 5.2 выдает такую же ошибку - она что перестала поддерживаться?
## Необходимая версия php

Минимально поддерживаемой версией в настоящий момент является 5.3. Существует поддержка вплоть до версии 5.5 (в данной версии в логах будет уведомление об использовании устаревших функций). Версия php 5.6 в настоящее время движком не поддерживается и его работа на ней не гарантируется. Мы делаем все возможное чтобы в самое ближайшее время добавить его поддержку. Для кого инструкции пишут?
 
Последнее редактирование:

Exile

Администратор
#3
Самое интересное, что отказ от поддержки php 5.2 был несколько лет назад, когда разработка еще на другом форуме велась. То есть даже не я инициатор. В дальнейшем все больше зависимостей добавлялось, это да.

@lexafromorel что у вас за хостер, ну или по крайней мере из какого вы к нам года пожаловали? Версия 5.3 у php уже не поддерживается, от нее все отказываются, в debian, где стандартные репозитории обновляются крайней редко уже и то php 5.4 минимально доступная версия. Давно пора было съехать с 5.2, а то уже 5.6 есть и 7.0 на носу, а вы на версии, которой 7 лет.
 
Сверху