Релиз TorrentPier Aurochs. Версия 2.2.1

Exile

Администратор
#1
Доброго времени суток.

Никогда большие релизы не обходятся совсем гладко, поэтому спустя всего несколько дней после

Please Login or Register to view hidden text.

, мы

Please Login or Register to view hidden text.

исправляющую основные найденные после релиза проблемы.

Благодаря использованию системы сбора ошибок удалось найти большую часть скрытых проблем, которые мы не смогли воспроизвести самостоятельно, но подавляющее число ошибок - ошибки самих пользователей. Хотелось бы напомнить следующие важные пункты, которые должны быть соблюдены для корректной работы новых версий:
  • PHP версии 5.6 и выше с модулями bcmath и intl, на младших версиях и без указанных модулей работать ничего не будет.
  • Права на запись в указанных

    Please Login or Register to view hidden text.

    папках и владелец файлов должен быть тот, от чьего имени работает ваш веб-сервер. Это базовое понятие для работы с любым PHP-скриптом, которое почему-то большинство пользователей игнорирует.
  • Сервер на основе Unix. Попытки запустить на OpenServer и т.п. системах под Windows, пускай даже и в ознакомительных целях ничем хорошим не заканчиваются как минимум из-за новой работы с email. В дальнейшем в движке будет поддержка Docker для не зависимого от платформы тестирования, а пока что вынужденно ограничиваем свои ресурсы поддержки согласно возможностям.
Также хотелось бы напомнить, что задать совершенно любые вопросы по обновлению на новую версию вы можете

Please Login or Register to view hidden text.

, в комнате #upgrade. Заходите, не стесняйтесь, тем более что есть и другие комнаты, в которых можно общаться куда более неформально чем тут.

Спасибо за внимание.
 

Kryl

Пользователь
#2
А надо на сервак какие либо пакеты устанавливать ?
На локалке (openserver) + моды, вроде все нормально работает , закинул файлы на рабочий сервер ... и понеслось ))) даже сообщение не отправить было ..
дальше юзать на рабочем серваке не стал ..
может что то установить надо .. ?
 

Exile

Администратор
#3

assasinfil

Пользователь
#4
А обновиться как? Тупо скопировать новый двиг поверх или чисто, а потом настроить заново?
 

Exile

Администратор
#8
Warrior Of Darkness, скачиваете 2.1.5, там в папке install есть информация какие запросы в базу выполнить, выполняете, а с 2.1.5 на 2.2.1 по аналогии.
 
Сверху