Релиз TorrentPier Aurochs. Версия 2.2.1

Тема в разделе "Новости ресурса", создана пользователем Exile, 16 июн 2017.

  1. Exile

    Exile Администратор

    Сообщения:
    3.113
    Симпатии:
    1.711
    Версия TP:
    2.2.3
    Доброго времени суток.

    Никогда большие релизы не обходятся совсем гладко, поэтому спустя всего несколько дней после релиза версии 2.2.0, мы готовы представить минорную версию 2.2.1, исправляющую основные найденные после релиза проблемы.

    Благодаря использованию системы сбора ошибок удалось найти большую часть скрытых проблем, которые мы не смогли воспроизвести самостоятельно, но подавляющее число ошибок - ошибки самих пользователей. Хотелось бы напомнить следующие важные пункты, которые должны быть соблюдены для корректной работы новых версий:
    • PHP версии 5.6 и выше с модулями bcmath и intl, на младших версиях и без указанных модулей работать ничего не будет.
    • Права на запись в указанных в README папках и владелец файлов должен быть тот, от чьего имени работает ваш веб-сервер. Это базовое понятие для работы с любым PHP-скриптом, которое почему-то большинство пользователей игнорирует.
    • Сервер на основе Unix. Попытки запустить на OpenServer и т.п. системах под Windows, пускай даже и в ознакомительных целях ничем хорошим не заканчиваются как минимум из-за новой работы с email. В дальнейшем в движке будет поддержка Docker для не зависимого от платформы тестирования, а пока что вынужденно ограничиваем свои ресурсы поддержки согласно возможностям.
    Также хотелось бы напомнить, что задать совершенно любые вопросы по обновлению на новую версию вы можете в нашем Slack, в комнате #upgrade. Заходите, не стесняйтесь, тем более что есть и другие комнаты, в которых можно общаться куда более неформально чем тут.

    Спасибо за внимание.
     
    Nikolay90, ExPlayer, Alexander.S и 7 другим нравится это.
  2. Kryl

    Kryl Пользователь

    Сообщения:
    891
    Симпатии:
    248
    Версия TP:
    2.2.1
    А надо на сервак какие либо пакеты устанавливать ?
    На локалке (openserver) + моды, вроде все нормально работает , закинул файлы на рабочий сервер ... и понеслось ))) даже сообщение не отправить было ..
    дальше юзать на рабочем серваке не стал ..
    может что то установить надо .. ?
     
  3. Exile

    Exile Администратор

    Сообщения:
    3.113
    Симпатии:
    1.711
    Версия TP:
    2.2.3
    Ну обычно при этом есть ошибки.

    А так вот:
     
    Kryl нравится это.
  4. assasinfil

    assasinfil Пользователь

    Сообщения:
    62
    Симпатии:
    2
    А обновиться как? Тупо скопировать новый двиг поверх или чисто, а потом настроить заново?
     
  5. Exile

    Exile Администратор

    Сообщения:
    3.113
    Симпатии:
    1.711
    Версия TP:
    2.2.3
  6. assasinfil

    assasinfil Пользователь

    Сообщения:
    62
    Симпатии:
    2
  7. Warrior Of Darkness

    Warrior Of Darkness Заблокирован

    Сообщения:
    75
    Симпатии:
    0
    А каким образом с R600 перейти на эту версию?
     
  8. Exile

    Exile Администратор

    Сообщения:
    3.113
    Симпатии:
    1.711
    Версия TP:
    2.2.3
    Warrior Of Darkness, скачиваете 2.1.5, там в папке install есть информация какие запросы в базу выполнить, выполняете, а с 2.1.5 на 2.2.1 по аналогии.
     
  9. assasinfil

    assasinfil Пользователь

    Сообщения:
    62
    Симпатии:
    2
    Распаковать архив, отредактировать файлы и обновить базу скриптом.
     
  10. Exile

    Exile Администратор

    Сообщения:
    3.113
    Симпатии:
    1.711
    Версия TP:
    2.2.3
    assasinfil, каким скриптом? Скриптов не выпускалось после 2.1.0 версии.
     

Поделиться этой страницей