memcahed

Dr_Brown

Пользователь
#1
Блин, взяли VPS, сдуру забsли сказать и там хостер Centos запилил, я както привык с debianom воевать....не могу понять по мемкшу, вроде установил через консоль, запустил пишет ок. Но запускается на 64 Мб....хочу ему 256 впихнуть, нахожу конфиг в /etc/sysconfig/memcahed/
открываю, прописано:
Код:
PORT="11211"
USER="memcached"
MAXCONN="1024"
CACHESIZE="64"
OPTIONS=""
ставлю:
Код:
PORT="11211"
USER="memcached"
MAXCONN="1024"
CACHESIZE="256" (без кавычек тоже пробовал)
OPTIONS=""
делаю в консоли servise memcached reload(restart,forced-reload) похер как, все ок пишет....., захожу к демону: в /ect/rc.d/init.d/memcached/, открываю
Код:
#! /bin/sh
#
# chkconfig: - 55 45
# description:    The memcached daemon is a network memory cache service.
# processname: memcached
# config: /etc/sysconfig/memcached
# pidfile: /var/run/memcached/memcached.pid
 
# Standard LSB functions
#. /lib/lsb/init-functions
 
# Source function library.
. /etc/init.d/functions
 
PORT=11211
USER=memcached
MAXCONN=1024
CACHESIZE=64
OPTIONS=""
 
if [ -f /etc/sysconfig/memcached ];then
    . /etc/sysconfig/memcached
fi
 
# Check that networking is up.
. /etc/sysconfig/network
 
if [ "$NETWORKING" = "no" ]
then
    exit 0
fi
................
..................
бля не меняет память....в чем херня.....?
 

dimka3210

Пользователь
#3
попробуй мемкеш не через сервис запускать, а прямой командой.
memcached -d -m 256
d - в режиме демона, m - понятно)
 

Dr_Brown

Пользователь
#4
dimka3210, спс попробую, а что скажешь на это:

[01-Apr-2014 21:42:11] PHP Notice: tidy_repair_string(): Unknown Tidy Configuration Option 'merge-spans' in /var/www/hrach/data/www/........../includes/bbcode.php on line 798

на эту фуньку:

Код:
    /**
    * tidy
    */
    function tidy ($text)
    {
        if (!function_exists('tidy_repair_string')) die('(see $bb_cfg[\'tidy_post\'] in config.php)');
 
798        $text = tidy_repair_string($text, $this->tidy_cfg, 'utf8');
        return $text;
    }
все способы предложенные на форуме, у же перепробовал не хера....tidy выключать не хочу...

даже это пробовал :

Please Login or Register to view hidden text.

 

dimka3210

Пользователь
#5
Dr_Brown, хотя ты не одинок )

Please Login or Register to view hidden text.


Но посмотри там статус. Не подтверждено. Попробуй поставить в конфиг tidy
merge-spans = false
 

dimka3210

Пользователь
#7
Ну как бы я хз где ты рыл). Но если перейти по ссылке которую я тебе дал, а потом поглядеть на твой пост #4 в этой теме, то сразу становится очевидно что смотреть нужно в $this->tidy_cfg твоего сообщения. Смотреть где инициализируется массив и там менять.
 

Dr_Brown

Пользователь
#9
да не парьтесь пацаны, хостер сервак переставил, на deb 6 и
PHP Version 5.3.3-7+squeeze19

все заработало...
 
Сверху