багом не является Несовместимость версий js bootstrap

smile

Заблокирован
#1
TP 2.2.3
Текущая версия bootstrap.js требует jquery 1.9.1 ! Текущая 1.8.х несовместима.
На новую версию (jQuery 3.2.1) вроде-бы обновляется безболезненно ! Повторяю, вроде-бы !
 

Protektor

Пользователь
#4
На новую версию (jQuery 3.2.1) вроде-бы обновляется безболезненно !
Не совсем так, не будет работать определение браузеров , без сторонних скриптов, а именно $.browser выпилили из jquery, в этом и проблемка и .size() в main.js тоже должно выдать ошибку, вот правда уже не помню какую, обнаруживается последняя когда в профиле юзера добавляешь или отнимаешь скачано/отдано и т.д.
решить это можно так:
качаем

Please Login or Register to view hidden text.


(и подключам соответственно, я прям в jquery.pack.js засунул)
далее в
файле main.js
.size()
заменить на
.length

ну и подключить сам 3.2.1 jquery предворительно закоментировав или удалив старый
в принципе все, я больше ошибок не заметил , тестил с неделю где то. Конечно 100% гарантии я не даю что у вас будет также, так как мало ли какие скрипты у вас установлены, как всегда все делаете на свой страх и риск. Замену производил на TP 223
 
Сверху