исправлено Ошибка при отправке ЛС

Kryl

Пользователь
#1
При отправке ЛС редирект на пустую страницу .
[15-Jun-2017 20:36:59 Europe/Moscow] Bugsnag Warning: Couldn't notify. json_encode error: Malformed UTF-8 characters, possibly incorrectly encoded
Как то работает через раз , от админа отправляшь - нормально , от юзера - пустая страница .
но письма доходят .
может я что то не установил ? на локалку ...
 

Kryl

Пользователь
#3
Swift_TransportException
Connection could not be established with host localhost [��������� �� �����������, �.�. ������ ������� ������ ������ �� ���������. #10061]


PHP:
E:\OpenServer\domains\60-fps.su\vendor\swiftmailer\swiftmailer\lib\classes\Swift\Transport\StreamBuffer.php
    {
        $host = $this->_params['host'];
        if (!empty($this->_params['protocol'])) {
            $host = $this->_params['protocol'].'://'.$host;
        }
        $timeout = 15;
        if (!empty($this->_params['timeout'])) {
            $timeout = $this->_params['timeout'];
        }
        $options = array();
        if (!empty($this->_params['sourceIp'])) {
            $options['socket']['bindto'] = $this->_params['sourceIp'].':0';
        }
        if (isset($this->_params['stream_context_options'])) {
            $options = array_merge($options, $this->_params['stream_context_options']);
        }
        $streamContext = stream_context_create($options);
        $this->_stream = @stream_socket_client($host.':'.$this->_params['port'], $errno, $errstr, $timeout, STREAM_CLIENT_CONNECT, $streamContext);
        if (false === $this->_stream) {
            throw new Swift_TransportException(
                'Connection could not be established with host '.$this->_params['host'].
                ' ['.$errstr.' #'.$errno.']'
                );
        }
        if (!empty($this->_params['blocking'])) {
            stream_set_blocking($this->_stream, 1);
        } else {
            stream_set_blocking($this->_stream, 0);
        }
        stream_set_timeout($this->_stream, $timeout);
 

Kryl

Пользователь
#5
на чистой версии вроде нормально стало с правкой выше .
а на версии с модами , сайт вообще умер ))))
 
Сверху