на модерации подскажите проверенную версию движка, на которой все работает,

laughingman

Пользователь
#1
Я установил новую версию движка, все вроде не плохо, но в ней ошибки в конструкторе шаблонов, из за js ошибки не формируется привью элементов формы.
Пожалуйста, подскажите в какой версии все работает нормально, на пример какой версией пользуетесь Вы
 

Exile

Администратор
#5
На последней все работает. Ставите старую версию - не пишите на форуме потом.
 

laughingman

Пользователь
#8
Я решил проблему, поставил последнюю версию, а конструктор взял из 2.1.5 теперь все работает. Но если вдруг будет интересно исправить именно в новой версии, то ошибка происходит в файле posting_tpl.tpl на 180 строке

var row_title = (TPL.el_attr[title_id] !== null) ? TPL.el_attr[title_id][1] : TPL.trim_brackets(title_id);

конкретно вот тут TPL.el_attr[title_id][1] //в title_id находится что-то вроде INP['some_name'], а имя свойства объекта TPL.el_attr просто 'some_name'.
То есть сели написать вот так

var row_title = (TPL.el_attr[title_id] !== null) ? TPL.el_attr['some_name'] : TPL.trim_brackets(title_id);

Отработает нормально, правда только одно поле).
 

dotWizard

Пользователь
#9
В последней версии 2.2.3 действительно не работает предпросмотр в конструкторе из за этой строки, вернее сейчас эта строка 170
Вот что получается _
Ну и соответственно создать шаблон не получается, выскакивают нотисы о незаполненном сообщении
 
Последнее редактирование:
Сверху