Повышение минимально поддерживаемой версии PHP: 5.4

Exile

Администратор
#1
Доброго времени суток.

28 августа прошлого года вышел PHP 5.6. С момента его выхода, поддержка версии 5.3 официально прекратилась. Большинство дистрибутивов ОС теперь по-умолчанию предлагают PHP более высоких версий (даже в консервативном Debian уже 5.4). Поскольку новые версии PHP предоставляют доступ к новым возможностям в разработке, начиная с версии 2.1.6 TorrentPier будет работать только с PHP 5.4 и выше. В версии 2.1.6 будут внесены необратимые изменения, которые потребуют перехода как минимум на указанную версию. Изменения будут не только визуальные, но и функциональные (новый алгоритм шифрования паролей). Поэтому в оставшиеся недели до выхода TorrentPier 2.1.6, озаботьте вашего хостера переходом хотя бы на PHP 5.4, если он этого еще не сделал.

Спасибо за внимание.
 

vitalix

Пользователь
#2
По теме пока горячо.
Хостер предоставляет версии до php 5.6
При переходе на 4.6 нотис :
Deprecated: mysql_escape_string(): This function is deprecated; use mysql_real_escape_string() instead. in /library/includes/page_header.php on line 218

if (!empty($userdata['username']))
{
218 строка $userrr = mysql_escape_string($userdata['username']);
DB()->sql_query("UPDATE bb_users SET last_visit = ".time()." WHERE username = '".$userrr."'");
}
 

sasha20072007

Пользователь
#3
P.S. Оказывается, достучаться до хостера с просьбой обновить до 5.4, так как переключение не предусмотрено, нужно потратить полдня и написать десяток писем в поддержку
thehost.com.ua
 

Exile

Администратор
#5
@slava CentOS давно 7 версии так-то есть.

@vitalix да, про устаревший модель поддержки баз данных в курсе. После его переноса на ZF, будет поддержка всех версий PHP от 5.4 до 7.0 включительно.
 

slava

Пользователь
#6
@Exile, конечно давно, но тут фича в том, что красные шляпы не рекомендуют апгрейдить с переходом на новую версию системы. С нуля всё ставить это небольшой риск и проблема доступности сервисов. В другом случае возможны проблемы с зависимостями. Если у кого есть что по этой теме - пишите
 

Exile

Администратор
#7
@slava в случае с php при переходе с 5.3 на 5.4 ровным счетом ничего критичного не было. Подключите Remi в список репозиториев, он стабильным относительно считается.
 
Сверху