решено Трекер через https

sniks87

Пользователь
#1
Добрый вечер, товарищи!
Пользуюсь TP II уже давно, есть один трекер на 400-ой ревизии, и вот решил создать тематический на 600-ой
После соблюдения всех пунктов установки возникла проблема с шифрование https, точнее SSL сертификатом. Ставил для теста на вирт.хостинг, делал самоподписанный SSL.
Помогите решить проблему, при переходе с login.php, браузер начинает ругаться из-за незащищенного соединения. Заранее спасибо!
 

PheRum

Разработчик
#2
если браузер ругается, значит SSL установлен не верно, либо он самопальный.
 

sniks87

Пользователь
#3
Ну да, он самопальный, просто с сертификатами никогда не сталкивался, кроме варианта, как купить, нету?
 

PheRum

Разработчик
#4
на самопальные сертификаты браузеры будут орать. это нормальная реакция.
хром постоянно на них орет и не дает открыть страницу, только после подтверждения руками, остальные браузеры спрашиваю, доверять ли такому сертификату, и после одобрения юзером начинают норм работать.
с куплеными сертификатами такой проблемы не будет.

самопального сертификата вполне хратит себе любимому или так, чисто потестить. для массового использования на сайте придется купить нормальный.

движок к сертификату отношения никакого не имеет
 

sniks87

Пользователь
#5
Даже без сертификата ругаются браузеры, после логина, он переходит на защищенку, т.е https, и даже без SSL ругается, просто когда 400-ую устанавливал, действительно, проблем таких не было
 

Exile

Администратор
#8
@sniks87 простой вариант - ставите ресурс под защиту

Please Login or Register to view hidden text.

- у вас фильтрация трафика от ботов + бесплатный сертификат валидный, как у нас. Ну или принудительно редирект настроить с https на http.
 
Сверху