решено Please install composer при установке 2.1.6

alexandr3636

Пользователь
#11
Ну это я понял, только я поставил его, но он все равно требует установки, по этому выше и задал вопрос, как дальше быть, ну по сути ладно, может на опер сервер и не станет, только как быть на хостинге, хостеры не хотят и слышать о каких то дополнений, или же новый двиг рассчитан только на свой юниксовый хост?
 

Exile

Администратор
#12
alexandr3636, вы его поставили, а теперь в папке с проектом надо сделать composer install, в случае с виндой наверное php.exe composer install.
 

Exile

Администратор
#15
Вы поставили сам composer, а теперь надо его запустить чтобы он скачал зависимости - тогда "ошибка" уйдет. Для тех кто не в состоянии будет осилить инструкцию - будет предсобранная версия.
 

PheRum

Разработчик
#16
Ну это я понял, только я поставил его, но он все равно требует установки, по этому выше и задал вопрос, как дальше быть, ну по сути ладно, может на опер сервер и не станет, только как быть на хостинге, хостеры не хотят и слышать о каких то дополнений, или же новый двиг рассчитан только на свой юниксовый хост?
если трекер стоит на хостинге и нет возможности установить composer, то можно закачать в корень сайта composer.phar (скачивается с офф сайта) и тогда уже в консоле выполнить php composer.phar update
 

alexandr3636

Пользователь
#17
Вот спасибо, за третий шаг пропустил, ну все равно остался один вопрос под вопросом, как быть с хостингом, или только свой юникс подымать надо, из за компосера?
 

Exile

Администратор
#19
alexandr3636, для тех у кого нет консоли будет собранная версия. Но в целом движок не ориентируется на shared-хостинги больше никак. И все же возможность распаковать и пользоваться как и раньше - будет.
 

alexandr3636

Пользователь
#20
Ну у нас не шатровый хост, довольно стойкий, платный, грех на него жаловаться, поддержка мгновенная, шустрая, всегда подскажут
 
Сверху